LabVIEW论坛

 找回密码
 注册

扫一扫,访问微社区

查看: 3590|回复: 14

[求助贴] 信号发生器的幅值不一样结果也不一样

[复制链接]
发表于 2009-4-15 09:42:01 | 显示全部楼层 |阅读模式
USB-6009数据采集卡首发
使用信号发生器提供信号来测量两个信号的相位差但是信号发生器的幅值不一样结果也就不一样啊?相差一度多中那么回事啊?谢谢各位大侠的指点啊。
IDAQ-USB-6009数据采集卡
发表于 2009-4-15 21:18:06 | 显示全部楼层
在线课堂
用示波器看看频率有没有变。
 楼主| 发表于 2009-4-18 09:53:42 | 显示全部楼层

回复 2楼 brightxie1 的帖子

我用的是信号发生器啊,而且我一直用labview里面的控件在提取信号的频率在实时监视,信号的频率小数点以后两位都没有变化啊。
 楼主| 发表于 2009-4-18 10:05:34 | 显示全部楼层
我一直在监测信号频率,小数点以后两位都不变啊,但是我的信号幅值不一样相位差的测量就是不一样。我用了5v和10v结果相差将近2度啊。这是怎么回事,大侠指点一下。谢谢。
QQ截图未命名.jpg
 楼主| 发表于 2009-4-18 14:08:06 | 显示全部楼层

回复 2楼 brightxie1 的帖子

谢谢你的建议,我发现一个问题就是可能我的实验里面没有加放大器,输入阻抗不是无穷大,我先加个放大器看看效果。
发表于 2009-4-18 21:22:27 | 显示全部楼层

回复 5楼 xiao-chao 的帖子

如果你给的信号是5v 和10v,就不需要用放大器了, 2 N; r9 s) _5 r0 V1 o; p) t0 Q# X1 r
你用的是什么采集卡,如果是NI的采集卡一般也不存在输入阻抗的问题,
8 l9 m9 |1 q$ @' C* F! S3 s% h因为ni采集卡输入是运算放大器, 输入阻抗可以认为是无穷大的。
 楼主| 发表于 2009-4-20 09:51:36 | 显示全部楼层

回复 6楼 brightxie1 的帖子

谢谢指点,我用的采集卡我也不知道是什么型号。我把两路信号接到cb-68lp上面。然后直接接到了电脑的后面接口里面。上次有位大侠回复说cb-68lp是个端口。不是采集卡,我也不知道怎么回事了。
发表于 2009-4-20 21:51:42 | 显示全部楼层

回复 7楼 xiao-chao 的帖子

CB-68LP是NI的接线板。) `+ ?, {  P4 z; H4 W2 {1 T, ^
它接的是NI板卡,你打开Measurement&Automation就可以看到你用的是什么板卡。! K! d3 q( c- P/ O  T
你也可以在电脑后面看连线的板卡,上面也有写板卡的型号,比如:PCI-6221,PCI-6220 or PCI-6023E等。
4 G8 z; i+ e6 P* d5 f3 l) s( }0 D+ d! U/ }( q  m" m# }1 Z
Bright
 楼主| 发表于 2009-4-21 09:11:56 | 显示全部楼层

回复 8楼 brightxie1 的帖子

哦,谢谢啊。我看一下再回来。
 楼主| 发表于 2009-4-21 09:17:01 | 显示全部楼层

回复 8楼 brightxie1 的帖子

我的采集卡是PCI-6024E这样的卡需要加上放大器再提高输入阻抗嘛?
您需要登录后才可以回帖 登录 | 注册

本版积分规则

QQ|小黑屋|无图浏览|手机版|网站地图|虚拟仪器家园 ( 沪ICP备06029130号-1 )

GMT+8, 2018-9-22 04:22 , Processed in 0.045226 second(s), 27 queries , Gzip On, MemCache On.

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表